Neon CRM Performance Issues
Incident Report for Neon One
Resolved
This incident has been resolved.
Posted Jul 15, 2024 - 16:54 CDT
Monitoring
Slowness with loading Neon CRM forms & pages should now be resolved. We are continuing to monitor the situation.
Posted Jul 15, 2024 - 12:40 CDT
Investigating
Some users have reported issues with Neon CRM forms & pages loading slowly. We are actively investigating the issue and will provide updates as soon as they are available.
Posted Jul 15, 2024 - 11:15 CDT
This incident affected: Neon CRM.