Neon Pay Charge Outage

Incident Report for Neon One

Resolved

Neon Pay has been fully operational since 11:28 am U.S. Central Time, and we have confirmed that all charges are processing as expected. We will reach out individually to the small number of organizations impacted by today's issue.
If you have any questions, please reach out to the Neon Pay Support team
Posted Mar 19, 2025 - 16:54 CDT

Monitoring

A fix has been implemented and charge processing has been restored. We will continue to monitor. We apologize for any inconvenience this has caused.
Posted Mar 19, 2025 - 11:37 CDT

Investigating

Neon Pay Charges are currently timing out. We are investigating this issue and will post an update shortly.
Posted Mar 19, 2025 - 11:26 CDT
This incident affected: Neon Pay.