Neon CRM Performance Issues
Incident Report for Neon One
Resolved
This incident has been resolved.
Posted Jul 30, 2024 - 23:28 CDT
Monitoring
Performance is back to normal across Neon CRM user pages and forms. We will continue to monitor systems until our web service provider confirms full restoration of service.
Posted Jul 30, 2024 - 21:37 CDT
Identified
Our web server provider (AWS) is currently experiencing a degradation of performance. This will cause Neon CRM back end pages and forms to load slowly or not at all. We are monitoring the situation closely and will send a notification as soon as there is an update.
Posted Jul 30, 2024 - 20:05 CDT
Investigating
We are investigating an issue that is preventing some user pages and forms from loading. We will share as soon as we have an update.
Posted Jul 30, 2024 - 18:14 CDT
This incident affected: Neon CRM.