Neon CRM Intermittent Slowness and Errors

Incident Report for Neon One

Resolved

We have identified the cause of intermittent slowness and error messages and have restarted our servers with no downtime. These issues appear to have been resolved. We will continue to monitor.
Posted May 21, 2025 - 14:13 CDT

Investigating

Some users have reported intermittent slowness and error messages when using Neon CRM. We are actively investigating.
Posted May 21, 2025 - 13:41 CDT
This incident affected: Neon CRM.