Some users unable to log in to Neon One applications

Incident Report for Neon One

Resolved

This incident has been resolved.
Posted Oct 03, 2025 - 14:48 CDT

Update

We are continuing to monitor this issue. We're seeing ongoing reports of a 404 error upon login - however, users can click "Go to Home" to proceed with login. Please use this path temporarily as we fix this remaining issue.
Posted Oct 03, 2025 - 10:46 CDT

Monitoring

A fix has been implemented for admin login issues. 429 errors are now resolved. We will continue to monitor to ensure errors do not reoccur.
Posted Oct 03, 2025 - 10:10 CDT

Identified

We are currently fixing an issue causing some users to be unable to log in to https://app.neonsso.com/login to access their Neon One applications. We are expecting brief downtime for user login while we release a fix for this issue. Front end forms and payments are not impacted.
Posted Oct 03, 2025 - 09:41 CDT
This incident affected: Neon Pay, Neon CRM, Neon Giving Days, Neon CCM, Arts People, and Neon Websites.