Disruption to Neon CRM Email Service

Incident Report for Neon One

Resolved

All delayed emails have been sent.
Posted Sep 15, 2026 - 18:45 CDT

Monitoring

We have implemented a fix for the problem. We estimate all emails that had been delayed will be sent in the next 30 minutes (by 7:00pm CDT).
Posted Sep 15, 2026 - 18:22 CDT

Identified

We have identified an issue in the Neon CRM email campaign system that has slowed down its ability to send emails. This has resulted in email campaigns sending much slower than normal. We have identified the root cause of the issue and are working towards its resolution.
Posted Sep 15, 2026 - 16:57 CDT
This incident affected: Neon CRM.