Arts People Outage

Incident Report for Neon One

Resolved

system performance has returned to normal
Posted Jul 01, 2025 - 15:36 CDT

Update

Developers are continuing to work on a fix for this issue but system is slowly coming back to normal on its own as loads are diminishing. We apologize for the inconvenience and will keep you updated.
Posted Jul 01, 2025 - 15:08 CDT

Identified

Our developers have identified the cause of the outage. We have temporarily neutralized the cause but are working on a more permanent fix. Until then users will experience slower load times.
Posted Jul 01, 2025 - 14:33 CDT

Investigating

Arts People is currently experiencing an outage. Team is investigating.
Posted Jul 01, 2025 - 14:11 CDT
This incident affected: Arts People.