CRM Latency

Incident Report for Neon One

Resolved

The issues regarding system latency have been fully resolved, all services have returned to normal operating parameters. We apologize for the inconvenience.
Posted Mar 17, 2026 - 14:10 CDT

Monitoring

Our team has addressed an issue with our database resulting in latency issues. We have implemented a fix and are monitoring the situation closely. We apologize for any inconvenience this might have caused.
Posted Mar 17, 2026 - 11:01 CDT
This incident affected: Neon CRM.