Loading performance has improved, but we're continuing to monitor closely to ensure that the issue is fully resolved.
Posted Jun 17, 2026 - 14:38 CDT
Update
We are continuing to investigate this issue with Neon Portal logins, but have not yet been able to pinpoint a resolution. Timeouts are intermittent so we recommend reloading. Load times are slow. Once you have completed Portal login and are inside your Neon One app, load times of the app are not affected. Front end forms and constituent/patron/fundraising pages are not affected by this issue.
Posted Jun 17, 2026 - 13:59 CDT
Investigating
We are currently investigating an issue where Neon Portal is loading slowly or timing out for many users. We are typically seeing logins resolve after a delay, but you may experience delayed login times to Neon One apps.
Posted Jun 17, 2026 - 12:34 CDT
This incident affects: Neon Pay, Neon CRM, Arts People, and Neon Websites.