Delay in Some Credit Card Processing
Incident Report for Neon One
Resolved
This issue has been resolved. Charges are processing normally.
Posted Apr 09, 2024 - 10:17 CDT
Monitoring
We are aware of a potential delay in some credit cards processing. You may see credit cards remain in the Pending status for longer than usual.

We will continue to monitor the situation and post updates as we learn more.
Posted Apr 08, 2024 - 13:43 CDT
This incident affected: Neon Pay.