Credit Card processing error with Neon Pay

Incident Report for Neon One

Resolved

After a period of monitoring, the issue has not recurred and this incident can be confirmed as resolved.
Posted Mar 12, 2026 - 17:01 CDT

Monitoring

A fix has been implemented and we are monitoring to ensure the issue does not recur.
Posted Mar 12, 2026 - 10:21 CDT

Identified

This issue has been identified and a fix is being implemented. Thank you for you continued patience, and keep posted for updates on issue resolution.
Posted Mar 12, 2026 - 09:51 CDT

Investigating

We have been made aware of and are currently investigating an issue with Credit Card transactions through Neon Pay. Users are receiving the error, 'You do not have access to this merchant account. If you think this is an error, check the organization_id or application_id included in your request.' Thank you for your patience as we identify and implement a fix.
Posted Mar 12, 2026 - 09:13 CDT
This incident affected: Arts People.