Neon Pay Merchant Application Error
Incident Report for Neon One
Resolved
This incident has been resolved. If you encountered this error and created duplicate merchants during the enrollment process, please contact the Pay Support team here: https://support.neonone.com/hc/en-us/requests/new?ticket_form_id=360003131772.
Posted Nov 06, 2024 - 09:00 CST
Identified
Neon Pay has identified a bug related to the merchant application. Affected users will see the following error under the Merchant Name field upon submitting a new application: "This name is already in use."

If you see this error, we recommend closing the merchant application and navigating to the Merchants tab. You should see your new merchant account in this tab, and this error should not impact your ability to begin processing with the merchant. If you have already encountered this error, please contact the Pay Support team here: https://support.neonone.com/hc/en-us/requests/new?ticket_form_id=360003131772.

We apologize for any inconvenience this has caused. This page will be updated once we release the fix.
Posted Oct 31, 2024 - 15:42 CDT
This incident affected: Neon Pay.