Neon CRM - Performance Issues
Incident Report for Neon One
Resolved
This incident has been resolved.
Posted Feb 21, 2024 - 12:07 CST
Monitoring
We are investigating reports of some system users receiving error messages or screens not loading in Neon CRM. The issues currently appear to have been resolved, but we will continue to monitor for any future disruptions.
Posted Feb 21, 2024 - 10:20 CST
This incident affected: Neon CRM.