Venmo button not appearing in browsers other than Safari on iOS devices

Incident Report for Neon One

Update

We have identified that the root cause originates with one of our service partners. We are in active communication with their technical team and are monitoring their progress closely for a resolution.
Posted Mar 10, 2026 - 16:12 CDT

Identified

The issue has been identified and a fix is being implemented.
Posted Mar 06, 2026 - 13:54 CST
This incident affects: Neon Pay, Neon CRM, and Arts People.