Neon CRM Limited Service Slowdown
Incident Report for Neon One
Resolved
This issue has been resolved.
Posted Dec 05, 2023 - 16:15 CST
Monitoring
A fix has been implemented and we are monitoring. Performance has returned to normal.
Posted Dec 05, 2023 - 14:59 CST
Identified
We are aware of an issue causing slow page loading for several Neon CRM systems, including both user pages and constituent pages. We are implementing a fix for this issue and expect it to be resolved shortly.
Posted Dec 05, 2023 - 14:47 CST
This incident affected: Neon CRM.