Slowdown when accessing admin interface

Incident Report for Neon One

Resolved

We identified the issue causing the slowdown and this incident has been resolved. Neon Client Case Management customers should see load times across the system operating as normal.
Posted Oct 10, 2025 - 10:32 CDT

Investigating

We are currently investigating an issue where customers on Neon Client Case Management may experience slowness when loading admin pages and reports.
Posted Oct 10, 2025 - 10:04 CDT
This incident affected: Neon CCM.