Arts People system slow down

Incident Report for Neon One

Resolved

We are monitoring the situation closely to ensure the issue does not recur. If you are still experiencing issues please reach out to Arts People support for assistance. Thank you again for your patience.
Posted Jul 07, 2026 - 16:25 CDT

Investigating

We've identified an intermittent issue causing some pages to load slowly, in some cases up to 30 seconds. Our team is actively investigating the root cause, and we'll share updates as soon as they're available. Thank you for your patience in the meantime.
Posted Jul 07, 2026 - 15:25 CDT
This incident affected: Arts People.