Neon CRM: Donation Form loading issues when suggested amount descriptions contain special characters

Incident Report for Neon One

Resolved

This issue was resolved as of 2:30am CST on June 16.
Posted Jun 16, 2026 - 08:31 CDT

Identified

We are currently investigating an issue where some donation forms may display as a blank grey page. If you are experiencing this, a temporary workaround is to remove any apostrophes ( ' ) or backslashes ( \ ) from your suggested donation amount descriptions in your form settings. Our team is actively working on a permanent fix and will provide an update once resolved. We apologize for the inconvenience.
Posted Jun 15, 2026 - 15:50 CDT
This incident affected: Neon CRM.