Intermittent slowdowns and outage

Incident Report for Neon One

Resolved

Beginning around 7:00PM CT and ending around 7:50pm CT on 9/25/25, the Arts People application experienced slow downs and periods of outage for customers on public and admin pages. We identified the root cause, implemented a fix, and have been monitoring to ensure that the issue is resolved. Further preventative measures are being taken to reduce issues of this kind. We apologize for any inconvenience this may have caused you.
Posted Sep 25, 2025 - 19:50 CDT

Identified

Arts People application experiencing slow downs and periods of outage for customers on public and admin pages. We identified the root cause and are implementing a fix.
Posted Sep 25, 2025 - 19:00 CDT
This incident affected: Arts People.