We are aware of an issue with mobile carriers in the US that is causing service disruption in the delivery of SMS messages for two factor authentication. We are actively monitoring the solution. We apologize for the inconvenience.
Posted Dec 01, 2025 - 16:08 CST
Identified
We are aware of an issue with mobile carriers in the US that is causing service disruption in the delivery of SMS messages for two factor authentication. We are actively working on an alternative solution. We apologize for the inconvenience and will provide an update shortly.
Posted Dec 01, 2025 - 12:29 CST
Monitoring
With the holiday rush upon us, we’re expecting increased activity on US mobile networks this Cyber Monday and GivingTuesday. You may experience temporary SMS delivery delays for two-factor authentication during this time.
Posted Dec 01, 2025 - 09:50 CST
This incident affected: Neon Pay, Neon CRM, Neon Giving Days, Neon CCM, Arts People, and Neon Websites.