The issues causing slow responses in Neon CRM are resolved. Please contact our support team with any further questions or concerns.
Posted Jun 11, 2025 - 09:21 CDT
Update
The issues causing slow responses in Neon CRM are resolved. We will continue to monitor. Please contact our support team with any further questions or concerns.
Posted Jun 10, 2025 - 17:19 CDT
Monitoring
A fix has been implemented and performance has returned to normal. We will continue to monitor closely. Please contact our support team with any further questions or concerns.
Posted Jun 10, 2025 - 12:44 CDT
Identified
We have identified the issue causing slow response times in Neon CRM and are working on implementing a fix. Updates will be posted here when we have more information.
Posted Jun 10, 2025 - 11:47 CDT
Investigating
We are currently investigating slow responses in Neon CRM. Updates will be posted here as more information is available.