Arts People experiencing slowdown

Incident Report for Neon One

Resolved

The slowdown has been resolved. Things should be running smoothly now. We're working on a long-term fix to prevent it from happening again. Thanks for your patience!
Posted Jun 02, 2025 - 12:47 CDT

Update

We are continuing to investigate this issue.
Posted Jun 02, 2025 - 12:46 CDT

Investigating

Arts People is currently experiencing a system slowdown. We have identified the issue and are actively working on a fix.
Posted Jun 02, 2025 - 10:23 CDT
This incident affected: Arts People.