Neon One MFA Code Delays

Incident Report for Neon One

Resolved

This incident has been resolved.
Posted Apr 24, 2025 - 12:04 CDT

Monitoring

A fix has been implemented. We will continue to monitor the situation.
Posted Apr 22, 2025 - 13:05 CDT

Identified

This morning, our Text Message Multi-Factor Authentication partner reported an incident involving delivery delays to multiple text message providers. Our provider is working with their carrier partners to resolve this issue. We will post updates as soon as they become available.
Posted Apr 22, 2025 - 11:06 CDT
This incident affected: Neon Pay, Neon CRM, Neon Giving Days, Neon CCM, Arts People, and Neon Websites.