Neon CRM: Custom Domain Issue
Incident Report for Neon One
Resolved
Issues with loading Neon CRM for users with custom domains have been resolved. We are monitoring the situation.
Posted Feb 22, 2024 - 16:40 CST
Investigating
We are investigating an issue affecting Neon CRM users with custom domains. We are aware that forms & pages may not be currently loading, and we will provide an update as soon as it is available.
Posted Feb 22, 2024 - 15:00 CST
This incident affected: Neon CRM.