Minor Slowdown - Neon CRM Next Generation Events data

Incident Report for Neon One

Resolved

This incident has been resolved.
Posted Mar 25, 2025 - 13:21 CDT

Monitoring

The delay is resolved as of 12:33pm CST and we are monitoring to ensure performance.
Posted Mar 25, 2025 - 12:40 CDT

Investigating

We have identified an issue where new events and sales made in the Next Generation Events module are not showing on the events list page and account pages immediately due to a data slowdown. We are currently working on a resolution. No data is lost, but data flow to the Events list and account pages has been slowed down - all data will appear as expected after a delay.
Posted Mar 25, 2025 - 11:34 CDT
This incident affected: Neon CRM.