Neon Pay Portal Timeout Error

Incident Report for Neon One

Monitoring

The fix has been implemented. Users are now able to access the Pay Portal and process charges as usual. We will continue to monitor the fix before closing this incident.
Posted Mar 16, 2026 - 10:56 CDT

Identified

We have identified the issue causing API and Pay Portal timeouts and are implementing a fix. As a correction to our earlier message, some charges were not able to process due to errors initiating the session. We apologize for any inconvenience this has caused, and we will provide another update when the fix is in place.
Posted Mar 16, 2026 - 10:48 CDT

Investigating

We are currently investigating an issue preventing some users from accessing Neon Pay. Charging is not affected. We will provide an update as we learn more.
Posted Mar 16, 2026 - 10:17 CDT
This incident affects: Neon Pay.