Neon CRM: Spamhaus Email Blocklist
Incident Report for Neon One
Resolved
This incident has been resolved.
Posted Feb 19, 2024 - 13:36 CST
Update
As of January 24th, Neon CRM email servers have been fully delisted from Spamhaus blocklists.

We are continuing to monitor the situation. In the event that you experience any email deliverability issues after January 24th, please contact crmsupport@neonone.com.
Posted Jan 24, 2024 - 14:52 CST
Monitoring
Neon CRM's email servers were added to Spamhaus blocklists due to some users' email practices. Examples of problematic behavior include sending emails to purchased lists or to constituents who have otherwise not consented to receiving communications from your organization.

Neon CRM is awaiting confirmation from Spamhaus as to a timeline for complete issue resolution. While we have taken steps requested by Spamhaus, recipients may still inconsistently receive emails sent from Neon CRM. We will provide an update when it is available.
Posted Jan 22, 2024 - 14:25 CST
Identified
Neon CRM email servers have been intermittently flagged by Spamhaus, an email blocklist manager. As a result, you may notice that some recipients inconsistently receive emails sent from Neon CRM. We are working with Spamhaus to resolve this and will provide an update when it is available.
Posted Jan 16, 2024 - 14:44 CST
This incident affected: Neon CRM.