Arts People System Slowdown

Incident Report for Neon One

Monitoring

A fix has been implemented and we are continuing to monitor to ensure the issue does not recur.
Posted Mar 03, 2026 - 15:26 CST

Update

We are seeing improved performance on admin and public pages but are still working to fully resolve the issue.
Posted Mar 03, 2026 - 14:22 CST

Update

We are seeing improved performance on admin and public pages but are still working to fully resolve the issue.
Posted Mar 03, 2026 - 13:05 CST

Update

We are continuing to work on a fix for this issue. Thank you for your continued patience as we get service restored.
Posted Mar 03, 2026 - 12:12 CST

Identified

The issue has been identified and we are working to implement a fix to resolve the issue. Thank you again for your patience.
Posted Mar 03, 2026 - 11:41 CST

Investigating

We are currently investigating an issue with the Arts People system that is causing admin and public page slow downs. Pages are taking anywhere from 20-60 seconds to load. We will update this status page as soon as we have more information on a solution. Thank you for your patience.
Posted Mar 03, 2026 - 10:28 CST
This incident affects: Arts People.